Email links are not working

Incident Report for Privy

Resolved

Issue resolved. Email redirect links are now working normally.
Posted May 29, 2025 - 20:25 EDT

Monitoring

We're actively working on a fix. Email redirect links will be restored gradually.
Posted May 29, 2025 - 20:15 EDT

Update

Our engineers have identified the problem with link redirection and are working on a solution
Posted May 29, 2025 - 16:24 EDT

Investigating

We're receiving reports that link redirection is resulting in "not found" errors. Our engineering team is investing this issue.
Posted May 29, 2025 - 14:39 EDT