Dashboard Intermittent Availability

Incident Report for Privy

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:23 EST

Update

The ongoing issues with Privy Landing Pages and Embedded Forms have been traced to an issue with one of our vendors, Cloudflare. We’re monitoring the issue, but you can also view their incident here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 09:23 EST

Update

Access to the Privy dashboard has stabilized. We are monitoring intermittent performance for landing pages and embedded forms.
Posted Nov 18, 2025 - 08:55 EST

Update

A fix is in place and we are continuing to monitor service performance.
Posted Nov 18, 2025 - 08:28 EST

Identified

Access to Privy’s dashboard is experiencing intermittent unavailability. We’ve identified the issue and are working with a vendor to resolve it. We do not believe this is impacting scheduled or sent emails or sms.
Posted Nov 18, 2025 - 07:59 EST
This incident affected: Dashboard and Privy Convert (Signup Integrations).