Landing page SSL error

Incident Report for Privy

Monitoring

We've implemented a remediation to our landing pages to resolve the SSL certificate issue.
Posted Sep 24, 2026 - 11:36 EDT

Investigating

We are currently troubleshooting an issue with landing pages returning an SSL certificate error
Posted Sep 24, 2026 - 11:25 EDT