A fix has been deployed. Emails are going out and events are being processed. Our engineering team is continuing to monitor the situation.
Posted Mar 18, 2025 - 17:06 EDT
Identified
Our engineering team has identified an issue causing a delay in email delivery and email event processing. We're working on a fix and will update this page once we have more information.
Posted Mar 18, 2025 - 16:41 EDT
This incident affected: Privy Email (Email Sending).