Service outage
Incident Report for Privy
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 16:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2020 - 16:01 EDT
Investigating
We are currently investigating this issue.
Posted Mar 16, 2020 - 15:55 EDT
This incident affected: Dashboard and Website Campaigns.