Email reporting is delayed
Incident Report for Privy
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 14:47 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2020 - 14:46 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 02, 2020 - 13:53 EDT
Investigating
We are currently investigating this issue.
Posted Jun 02, 2020 - 13:42 EDT
This incident affected: Dashboard and Email Infrastructure.