Deliverability degradation
Incident Report for Privy
Resolved
This incident has been resolved.
Posted Nov 20, 2021 - 15:40 EST
Update
We are continuing to work on a fix for this issue. We have implemented some mitigations for about half of affected merchants, and are continuing to apply mitigations to the remaining affected accounts.
Posted Nov 19, 2021 - 17:42 EST
Identified
We have identified an increase in bounce rates and spam filtering for merchants without a custom sending domain. We are actively working to address this issue. Merchants can mitigate this issue by connecting a custom sending domain.
Posted Nov 19, 2021 - 11:46 EST
This incident affected: Privy Email (Email Sending).